The Blog is Hot

Openjdk og netbank

Posted in diverse by mschlander on 27/10/2008

Jeg er kunde i Forstædernes Bank, som bruger netbank-løsningen fra Bankernes EDB Central (BEC). Det samme gør næsten alle andre banker, med undtagelse af Danske Bank, Nordea og Jyske Bank, så vidt jeg ved.

I det store hele har det fungeret fint for mig som GNU/Linux-bruger, men det har betydet, at 1) jeg var afhængig af Sun Java, som stadig har enkelte ufri komponenter og dermed 2) jeg var afhængig af 32-bit Firefox, da Sun ikke leverer et 64-bit browser-plugin til Java.

Det er med stor glæde at jeg konstaterer, at et af problemerne er løst, siden i dag kan jeg benytte min netbank med Openjdk 1.6 på openSUSE 11.0, når jeg bruger pakkerne fra dette repository på openSUSE Build Service: http://download.opensuse.org/repositories/Java:/openjdk6:/Factory/openSUSE_11.0/

Sun Java er hermed fortid på mit system, da jeg ikke bruger Java i andre sammenhænge. På openSUSE 11.1 vil Openjdk i øvrigt være standard. Træerne vokser dog ikke ind i himlen, med kombinationen af 64-bit Firefox og 64-bit Openjdk segfaulter Firefox under login til netbanken. Så foreløbig må jeg stadig leve med at køre 32-bit Firefox på mit i øvrigt 64-bit system. Men andre applets – i hvert fald test-appletten på Java.com – virker, så afhængigt af hvilke Java-applets man skal bruge, kan Openjdk måske løse Java-problemet på 64-bit-systemer for mange allerede i dag.

Jeg er nysgerrig efter at høre om andres erfaringer med Openjdk. Har nogen fået det til at fungere med BEC-netbank på et rent 64-bit-system? Hvordan virker det med de andre netbank-systemer?

Advertisements

5 Responses

Subscribe to comments with RSS.

  1. Peter said, on 27/10/2008 at 22:00

    Jeg har godt nok ingen erfaring med Openjdk, men synes lige det skal nævnes at Suns Java kører faktisk fint i den 64bit version af Konqueror, så den bruger jeg til min netbank, hvilket gør at jeg også kan køre med 64bit versionen af Firefox.

  2. mschlander said, on 27/10/2008 at 22:53

    Hvilken netbank og hvilken version af Konqueror?

    Det er korrekt at (i hvert fald KDE3-versionen af) Konqueror, fungerer fint med 64-bit Sun Java. Men med BEC-netbank har den altid crashet for mig når jeg forsøgte at godkende BECs certifikat 😦

  3. Peter said, on 28/10/2008 at 10:42

    Sparnord. De bruger SparekassernesDataCenter (sdc.dk) version, og jeg benytter Konqueror 3.5.9 (under KDE 3.5.9 “release 49.1”) på openSUSE 11.0.

    Og du har ret i at Java tilsyneladende ikke virker Konqueror 4.1.1

  4. Dennis Jensen said, on 01/11/2008 at 22:13

    > Hvordan virker det med de andre netbank-systemer?

    Jeg bruger Sydbank med nøglekort, så der er slet ingen Java involveret. Det har fungeret så fint, at intet andet kommer på tale for mit vedkommende. Certifikat-løsning er mulig, men den er simpelthen for besværlig, og det tog for lang tid at hente Java-applet’en, hver gang jeg loggede på systemet. Det oplever jeg intet af længere. Til gengæld er det nye AJAX-kosmetik ved at blive lige tungt nok at danse med, men indtil videre går det.

  5. René said, on 13/02/2009 at 7:59

    Her kører netbank på SDC godt: Firefox + OpenJDK (build 1.6.0_0-b11) på 64 bit Kubuntu.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: